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How to translate projects for MT500 model to

MT8000/eMT3000 model

EasyBuilder provides a feature to translate project files used on
MT500 models and download them to MT8000/eMT3000 models. In
this way, the project files can be upgraded without being rebuilt.

The following demonstration explains how to translate a MT500
project file and use it on an eMT3000 model.

/\

Step 1 Since EasyBuilder Pro (EB Pro) can only convert from .eob
format file, open the .epj file in EasyBuilder500 (EB500)
to convert first. Click [Tools] » [Compile] to convert
the .epj file to an .eob file. If the file is already an .eob file,
skip this step.

e EasyBuilder - [ Testepj : Window 10 - Initial Screen)
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Step 2. Launch EB Pro, click [Tools] » [Translate MT500 Project].

Translate MTS00 Project...

Data/Event Log Converter o
=| o of ol

Decompile...
Q Easy Watch
.39 Administrator Tools

Recipe Database Editar...

Step 3. Select the .eob file and the needed functions, click
[Translate] to start translating.

MT500 EOB file : |C:\Users\user\Desktop! Test.eab Browse...
eMT3000 project : |C:\Users\user\Desktop! Test.emtp Browse...
Default font
ASCII : | Times New Roman v| | Font Size Table... ]
MNon-ASCIL: =R -

Use MTS00 ASCII font files (suggestion : check this box)
lUse the most suitable font size automatically (suggestion : check this box )

[ Delete "Direct Window" objects which are triggered with LE9060~9069, 9080, 9081.
{eMT3000 SERIES uses a new mechanism to manage keyboards.)

Stop l [ Translate l l Exit ]
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3.1 In [MT500 EOB file] box select the .eob file.

3.2 In [eMT3000 project] box enter the directory and file name to
store the translated file.

3.3 EB500 uses Dos Font whereas EB Pro uses Windows True Font.
When translating the project, select [Use MT500 ASCII font files]
and [Use the most suitable font size automatically] if needed.

3.4 If not selecting [Use the most suitable font size automatically],
click [Font Size Table] to select the font size used when
translating EB500 font to EB Pro font.

(Font See Translation Table

Font sizes of ASCII strings Font sizes of non-ASCII strings
MTS00 >  eMT3000 MTS00 ->  eMT3000

g = |9 - | g > |o - |

16 > [10 - | 16 -> [10 - |

24 > |16 v| 24 > |16 - |

32 > [20 v| 32 > (20 - |

48 > [36 v| 48 > |36 -

64 > [40 -| 64 > [40 -

72 > |56 - 72 > |56 -

9% -> [72 - % -> |72 -]

| UseDefault | [ oK | [ cancel |

(Note: When the font size is bigger than the object size, Text
object cannot display complete content.)

3.5 In EB500, to trigger a popup keyboard, a Direct Window which
works together with relative system tags is needed. In EB Pro,
the popup keyboard can be set simply by selecting the window
number when creating the object. Therefore, it is recommended
to select [Delete “"Direct Window” objects which are triggered
with LB9060~6069, 9080, 9081.] check box.
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Step 4. After translation, the “succeeded” message is displayed.
Click [Exit] to leave.

MT500 EOB file : |C:\Users\user\Desktop! Test.eab Browse...
eMT3000 project : |C:\Users\user\Desktop! Test.emtp Browse...
Default font
ASCII: Times New Roman || Font Size Table... ]
Mon-ASCII : 1=iE5E -

[[Juse MTS00 ASCII font files (suggestion : check this box)
lUse the most suitable font size automatically (suggestion : check this box )

Delete "Direct Window" objects which are triggered with LB9060~9069, 9080, 9081.
{eMT3000 SERIES uses a new mechanism to manage keyboards.)

Window 2 finished "
Window 3 finished
Window 5 finished
Window 4 finished
Window 10 finished
window 50 finished
Window 51 finished

succeeded -

[ Stop l I Translate ] [ Exit l

Step 5. The translated file is stored in the specified directory. Click
[File] » [Open] to open the .emtp file.

‘| File | Tool Help
_I"WN:w QuisN P K2 Gy | 4 G i EFEEANEG SA0 1 2 3 4 b sateo
o = =
& open.. Sl las === 2 A 0] <]L1 L2 L3 L4
1 C\Users\user\Desktop\Recipe S| G ool ol |3l F OIS a]] fed = dboda da LT I | ea = J100% o
El 2 Ch\Users\user\Desktop'Template ®
3 CAE-mail
g .
Exit s
vy | Lookin: [l Desktop - @ l& E® [
@ .5 =
“q [ Q jﬁ' @ Libraries h user
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10 ! M Systemn Folder @ Systemn Folder
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Step 6. When open the .emtp file, [System Parameter Settings]
dialog box appears. Select a HMI model.

| Extended Memory | Printer Backup Server | &-Mail | Recipes
Model | Devie | General | Systemsetting | Secuity | Font

HMI model ;
. . eMT3105 (800 x 600)
HMI station no : eMT3120/eMT3150 (1024 x 753
Portno. : '

Step 7. The screen size of the selected model may be different
from that of the MT500 model. Therefore, the following
dialog box appears. Select whether to resize windows or
objects and click [OK] to finish translation.

General windows

Resize pop-up windows
Resize objects

Keyvboard windows
Resize keyboard windows
Resize function key objects

| K | | cancel
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Notes

Generally, most of the translations can be done following the steps
described earlier. However, some objects or features designed
differently in EB500 and EB Pro. Some steps which are more
complicated is simplified and improved in EB Pro, and some features
can’t be translated by EB Pro and therefore requires users to adjust
manually. Please note if the following items are used in EB500
project file, and check carefully on the content.

Improved features

Combines Alarm and Event Log

Adds scroll bar on Alarm Display / Event Display objects.
Adds scroll bar on Trend Display object.

Combines Recipe Transfer object with Data Transfer
(Trigger-Based) object.

Changes the limits of keyboard value entry.

YV VYV

Y

Manually adjust features
Window size

Security class (user password)
Popup window

RS485 default communication interface
Data displayed in keyboard window
Trend Display

Label Tag Library

Customized Address Tag Library
Language

Window name

Object description

VVVVVVVYVYVYYVYYVY
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Improved features

» Combines Alarm and Event Log
In EB500, alarms are logged in Alarm Scan object and events are
logged in Event Log object. EB Pro combines these two types of
logs in Alarm (Event) Log object.

» Adds scroll bar on Alarm Display / Event Display objects.
EB Pro includes scroll bars on Alarm Display / Event Display
objects. Users don’t have to create a word register to control
event display in EB Pro.

» Adds scroll bar on Trend Display object.
EB Pro includes scroll bars on Trend Display objects. Users don't
have to create a word register to control trend display in EB Pro.

» Combines Recipe Transfer object with Data Transfer
(Trigger-Based) object.
EB Pro includes the functions of Recipe Transfer object on Data
Transfer (Trigger-Based) object.

» Changes the limits of keyboard value entry.
The format of value entry in EB500 is 32-bit sighed, whereas the
format of value entry in EB Pro is 32-bit float.

www.weintek.com
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Manually adjust features
» Window size
The screen size of MT500 may be different from that of the new

model. If so, adjust the screen size of the project..

1. In EB Pro, right-click on the window tree in project and select
[Attribute] to check the current window size.

Mame @ Window_10

Window no. :

Size

Width : 800 Height : 480

Frame

W'rdth:[l v] Color: | ||v|

2. In [System Parameter Settings] check the current HMI model
type and its resolution.

[System Parameter Settings ==

Extended Memory | Printer Backup Server | -Mail | Recipes
Devie | Model | General | SystemSetting | Secuity |  Font
HMI model ; [mm (800 x 430) "]
HMI stationmno : 0 -
Portno. @ 8000 {used as MODBUS server's part no.)

3. Ifthe resolution of the model is different from the project window
size, please change the project window size by switching to
another model.

FAQ Demonstration:
FAQ 07 Switch MT8000 Project between HMI Models
Video Demonstration:

EasyBuilder - Resize
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» Security class (user password)

The security mechanism in EB500 mainly protects windows, and only
three accounts are allowed. In EB Pro, not only windows but also
objects on windows can be protected by different security classes. EB
Pro provides two security modes, [General mode] and [Enhanced
security mode]. [General mode] provides 12 user accounts and 6
security classes whereas [Enhanced security mode] provides 12 user
accounts and 12 security classes. Secret user and User Account
Control (UAC) are available in [Enhanced security mode]. Since the
security mechanism in EB500 is completely different from EB Pro,
this function can’t be translated. Please set the security mechanism
again after translation.

[System Parameter Settings ==

Extended Memory | Printer Backup Server | -Mail | Recipes
Devie | Model | Gemeral | SystemSetting | Secuity | Font
(7 General mode i@ Enhanced security mode
Select operable dasses for each user
Use existing user accounts on HMI
Ho. Enable  Secret usr Ter name Pazzwond Claz s =~
1 nzerl 1
2 nerd 2
3 1z’ 3
4 nzrd 4
5 s ]
f nErh f
7 nzer’? 7 i
o = = a1 n =]
< | m | b
(EB Pro)

See EasyBuilder Pro User Manual: Chapter 10 Security

[General mode] Demonstration: Security
[Enhanced security mode] Demonstration: Enhanced Security



http://www.weintek.com/download/eMT3000/eng/UserManual/UserManual_separate_chapter/Chapter_10_Security.pdf
http://www.weintek.com/download/MT8000/Project/Part_Sample/Security.zip
http://www.weintek.com/download/eMT3000/Project/System_Sample/Enhanced_Security.zip
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» Popup window

In EB500, a popup window can be closed by selecting [Change
window] when setting a Function Key object, and at the same time
change to another window. In EB Pro, the change window action and
close popup window action are separated. The popup window has to
be closed by selecting [Close window] when setting a Function Key
object. If in EB500, [Change window] check box is selected, please
select [Close window] in EB Pro after translation.

General | Shape | Label | Profile |
Diescription ; |
() [ENT] © [B5] © [CLR] () [ESC]
o weci © Hord opy
@ Change window (71 Retum to previous
(71 Change common window Windowna. - 10

(EB500)
Furthermore, in EB Pro, [Close this popup window when parent
window is closed] check box on [Function Key Object’s Properties]
dialog box is selected by default after translation. If this function is
not needed, clear the selection manually.

General |Seﬂ_ﬂtflglape |Lahd |me'iE|

Description : |
Activate after button is released

(71 Change full-screen window 7) Change common window
(@) Display popup window

Close this popup window when parent window is dosed

Style : |No titie bar -

Window na, [11_ Window_11 ot

(EB Pro)

www.weintek.com




How to translate projects for MT500
1
RWE‘NTEK model to MT8000/eMT3000 model m

» RS485 default communication interface

The [RS485 default] selection is not available in EB Pro PLC I/F
setting, therefore, after translation, the interface may be changed to
another one. Please select the correct PLC I/F in EB Pro.

PLC | General | Indicator | Security | Editor | Hardware | Awc. |

PLCtype : [OMRON CJ1/CS1/CPIH [PDS V250] |
HMImodel : | MT510T/MT508T (640 40) -
PLC I/F port : [RS485default Baud rate :
(EB500)

» Data displayed in keyboard window

EB500 writes the data entered by keyboard to registers from
LW-9060 through LW-9075. EB Pro writes the data entered by
keyboard to LW-9150. Please check the ASCII Display object (AD_0)
in window number 50 and 51 to see if the translation is correct.

» Trend Display

In EB500, when setting Trend Display object, the [Hold trend display]
selection for [Hold style] is not loaded in EB Pro after translation. In
EB Pro, please select [Data Sampling] object and set [Clear address]
and [Hold address].

[Create Trend Display Objet ~~ [mzsl|

Page type : | Muliiple pages  ~ | No. of page : |1 - |
Hold style Attribute : | Start from left v |

Hold trend display |

Sampling time {1014 trend display & clear Plot point ;10
Read address
Device type : [HW v] Device address : 0
|BIN »|  No.of channel : [1 - |

www.weintek.com
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Description : PLC name : [Lodi-m v}
Sampling mode Clear address
@ Time-based () Trigger-based Enable Mode :
Sampling time interval : PLC name :[Loal HMI vl Setting...
Address : (1B - |0 ‘
Read address Hold address
PLC name :[L‘]ﬁ HMI - | Setting... Enable Mode :
Address : | Lw >0 | PLC name :[Lgal HMI - |[ Setting... ]
Address : (|5 |1
Data Record
Max. data records (real-time mode) : 1000 [ Auto. stop History fles
Data length: 0 word(s) [ Save to HMI memory [Fsave to SD card
[ save to USB disk
[ oK ] [ Cancel
(EB Pro)

> Label Tag Library

The format of Label Tag Library in EB500 is different from the format
in EB Pro. Please follow the steps to use the data of Label Tag Library
in EB Pro.

1. In EB500, open Label Tag Library, and click [Export CSV File].
| |

[ pie ][ wedy ][ oo ] [ EwonCov re.. | | impon Cov .. |
Bwone ] [ ot ]

Ok J[ Gamcel || ooy |[ Hep |

2. Open the .csv file by using Office Excel, edit the file and save to

a .xls file.
3. In EB Pro, open Label Tag Library, and click [Import Excel File].

www.weintek.com
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Label Tag Library =]

Label |Font

Language no., : 24 -

Stateno.: g v@@@@@

Mo. | Label tag name

[ cooy [ Paste | [ Export ExcEL Fie... [ [ mmportExceL Fie... |

» Customized Address Tag Library

The format of Address Tag Library in EB500 is different from the
format in EB Pro. Please follow the steps to use the data of Address
Tag Library in EB Pro.

1. In EB500, open Address Tag Library, click [Export CSV...].
[tagtibosy &

Tag test mode : BIT address ! LB 1}

www.weintek.com
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2. Open the .csv file by using Office Excel. The file is similar to the
following figure.

4 & | B | ¢ |
-1 Coffee LW 0
-2 Tea LW 1
- 3 Calories LW 2
-4 Sugar LW 3
-2 Milk LW 4
- B Price dx 0

3. Insert a column between column A and B, and enter the device
name as shown in the following figure.

I B | ¢ | p |
1 Coffes Local HMI LW {
2 Tea Local HMI LW 1
4 Calories  Local HMI LW 2
4 Sugar Local Hidl LW 3
o Milk Local HMI LW 4
6 Price MODEUS RTU 4z 0

In EasyBuilder, please see [System Parameter Settings] » [Device
list] to find the device name.

rﬁg.rstem Pararneter Settings @‘
| Extended Memary | Printer [Backup Server | e-Mail | Recipes
Device Model | General | systemseting | seawity | Font
Device list :

anaﬁnn Device type
Local HMI | Local HMI ».:I"-:1T"fl?f'l (800 x ... | Disable

MODBUS RTU MODBUSRTU  COM1 (9600,E81) -

4. In EB Pro, open Address Tag Library, click [Import CSV...].

* Users can import MT200 tag to represent the address.

[ Mew. )| Delete ][ DeleteAr || Setngs.. |
| SaveTagFie. || LoadTagFie.. |
| EBpotcsV. [|[ mpotCsV.. || Ewot EXCEL. |[ impot EXCEL.. |

www.weintek.com
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» Language
Chinese language contains Simplified Chinese and Traditional Chinese.
After translation, if incorrect font is displayed in the file, please follow
the steps to translate again.

1. In Easy Manager, use [Off-line simulation] to check current
language of the project.

2. On PC, go to [Control panel] » [Region and Language] »
[Administrative] tab and set current language for non-Unicode
programs according to the current language of the project.

| Fommats | Location | Keyboards and Languages | Administrative |

Welcome screen and new user accounts

View and copy your international settings to the welcome screen, system
accounts and new user accounts,

@Cﬂp}l‘ settings...

Tell me more about these accounts

Language for non-Unicode programs

This setting (systern locale) controls the language used when displaying
text in programs that do not support Unicode,

Current language for nen-Unicode programs:

Chinese (Traditional, Taiwan)

| Change system locale... |

3. When finished, restart PC, and translate the .eob file of EB500
again. The font should be correctly displayed.

www.weintek.com




How to translate projects for MT500
1
RWE‘NTEK model to MT8000/eMT3000 model

» Window name
The window names specified in EB500 will be renamed by window

numbers after translation.

Windows  wx
| Objest s )
- 31 Fast Selection it
w4y Common Window |j-|
1

.. B

- 11 Password Restriction

. B

L
410 : Window_10

-1 11 s Window 11

-112: Window_ 12

- 13 Window 13

- 14 Window 14
T

> Object description
The descriptions specified in EB500 will be cleared after translation.

General | Securi QlapelLahel |P'mﬁe|

Description :

Activate after button is released
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